guru/sys-apps/dool/dool-1.3.1-r1.ebuild
Anna (cybertailor) Vyalkova bb0aae8ad3
*/*: disable py3.10
Python 3.10 target is scheduled for removal in Gentoo:
https://public-inbox.gentoo.org/gentoo-dev/e6ca9f1f4ababb79ab2a3d005c39b483c3ecef6e.camel@gentoo.org/

Sphinx 8.2.0 already dropped support for CPython 3.10 and PyPy 3.10,
leading to multiple CI failures in ::guru.

We can safely remove this target, because GURU is "experimental" and
does not have stable keywords.

Let's not remove "pypy3" right now because
a) There are not many packages using it.
b) So we can see which packages supported PyPy 3.10, and test them with
   PyPy 3.11.

Closes: https://github.com/gentoo/guru/pull/291
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
2025-02-21 17:51:14 +05:00

60 lines
1.0 KiB
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
inherit python-r1
DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat (clone of dstat)"
HOMEPAGE="https://github.com/scottchiefbaker/dool"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/scottchiefbaker/dool.git"
inherit git-r3
else
SRC_URI="
https://github.com/scottchiefbaker/dool/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz
"
KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86 "
fi
LICENSE="GPL-2"
SLOT="0"
IUSE="doc examples"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
src_compile() {
:
}
python_install() {
python_doscript "${PN}"
python_domodule plugins/${PN}_*.py
}
src_install() {
python_foreach_impl python_install
doman "docs/${PN}.1"
einstalldocs
if use examples; then
dodoc examples/{mstat,read}.py
fi
if use doc; then
dodoc docs/*.html
fi
}
src_test() {
python_foreach_impl emake test
}