guru/sci-mathematics/pyromaths/pyromaths-21.8.2-r1.ebuild
Anna (cybertailor) Vyalkova bb0aae8ad3
*/*: disable py3.10
Python 3.10 target is scheduled for removal in Gentoo:
https://public-inbox.gentoo.org/gentoo-dev/e6ca9f1f4ababb79ab2a3d005c39b483c3ecef6e.camel@gentoo.org/

Sphinx 8.2.0 already dropped support for CPython 3.10 and PyPy 3.10,
leading to multiple CI failures in ::guru.

We can safely remove this target, because GURU is "experimental" and
does not have stable keywords.

Let's not remove "pypy3" right now because
a) There are not many packages using it.
b) So we can see which packages supported PyPy 3.10, and test them with
   PyPy 3.11.

Closes: https://github.com/gentoo/guru/pull/291
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
2025-02-21 17:51:14 +05:00

52 lines
1.1 KiB
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DOCS_BUILDER="sphinx"
DOCS_DEPEND="
dev-python/sphinx-argparse
"
DOCS_DIR="Doc/source"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{11..12} pypy3 )
inherit distutils-r1 docs
DESCRIPTION="Create maths exercises in LaTeX and PDF format"
HOMEPAGE="
https://pyromaths.frama.io/pyromaths-staticsite
https://pypi.org/project/pyromaths
https://framagit.org/pyromaths/pyromaths
"
SRC_URI="https://framagit.org/${PN}/${PN}/-/archive/version-${PV}/${PN}-version-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-version-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"
RDEPEND="
dev-python/lxml[${PYTHON_USEDEP}]
dev-tex/latexmk
dev-texlive/texlive-pstricks
dev-texlive/texlive-basic
dev-texlive/texlive-latexextra
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-mathscience
"
BDEPEND="
dev-python/jinja2-cli[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/setuptools.patch"
)
distutils_enable_tests pytest