mirror of
https://github.com/gentoo-mirror/guru.git
synced 2025-04-18 07:19:01 -04:00
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
40 lines
852 B
Bash
40 lines
852 B
Bash
# Copyright 2021 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
|
|
inherit meson
|
|
|
|
DESCRIPTION="A wayland based logout menu"
|
|
HOMEPAGE="https://github.com/ArtsyMacaw/wlogout"
|
|
SRC_URI="https://github.com/ArtsyMacaw/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
|
|
|
LICENSE="MIT"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64 ~x86"
|
|
IUSE="layershell doc bash-completions fish-completions zsh-completions"
|
|
|
|
DEPEND="x11-libs/gtk+[wayland(-)]
|
|
dev-libs/gobject-introspection
|
|
doc? ( app-text/scdoc )
|
|
layershell? ( gui-libs/gtk-layer-shell )"
|
|
RDEPEND="${DEPEND}"
|
|
|
|
src_configure() {
|
|
local emesonargs=(
|
|
$(meson_feature doc man-pages)
|
|
$(meson_use bash-completions)
|
|
$(meson_use fish-completions)
|
|
$(meson_use zsh-completions)
|
|
)
|
|
meson_src_configure
|
|
}
|
|
|
|
src_compile() {
|
|
meson_src_compile
|
|
}
|
|
|
|
src_install() {
|
|
meson_src_install
|
|
}
|