guru/gui-apps/swayrbar/swayrbar-0.4.2.ebuild
Nicolas PARLANT 2cc78789e1
gui-apps/swayrbar: restore marker comment for LICENSE+=
Signed-off-by: Nicolas PARLANT <nicolas.parlant@parhuet.fr>
2024-11-22 11:47:03 +01:00

39 lines
907 B
Bash

# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CRATES="
"
inherit cargo
DESCRIPTION="A swaybar-protocol implementation for sway/swaybar"
HOMEPAGE="https://sr.ht/~tsdh/swayr/"
SRC_URI="https://git.sr.ht/~tsdh/swayr/archive/${P}.tar.gz"
SRC_URI+=" https://raw.githubusercontent.com/PPN-SD/vendor/refs/tags/swayr-${P}/swayr-${P}-crates.tar.xz"
S="${WORKDIR}/swayr-${P}/"
LICENSE="GPL-3+"
# Autogenerated by pycargoebuild
# Dependent crate licenses
LICENSE+=" Apache-2.0 BSD-2 MIT MPL-2.0 Unicode-DFS-2016"
SLOT="0"
KEYWORDS="~amd64"
QA_FLAGS_IGNORED="/usr/bin/${PN}"
src_prepare() {
default
sed -i -e '/^lto =/d' -e 's/^strip = "symbols"$/strip = false/g' Cargo.toml || die "failed to sed Cargo.toml"
}
src_install() {
cargo_src_install --path ${PN}
}
pkg_postinst() {
elog "Verify the dependencies of every module you intend to use."
}