mirror of
https://github.com/gentoo-mirror/guru.git
synced 2025-04-18 07:19:01 -04:00
Python 3.10 target is scheduled for removal in Gentoo: https://public-inbox.gentoo.org/gentoo-dev/e6ca9f1f4ababb79ab2a3d005c39b483c3ecef6e.camel@gentoo.org/ Sphinx 8.2.0 already dropped support for CPython 3.10 and PyPy 3.10, leading to multiple CI failures in ::guru. We can safely remove this target, because GURU is "experimental" and does not have stable keywords. Let's not remove "pypy3" right now because a) There are not many packages using it. b) So we can see which packages supported PyPy 3.10, and test them with PyPy 3.11. Closes: https://github.com/gentoo/guru/pull/291 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
64 lines
1.2 KiB
Bash
64 lines
1.2 KiB
Bash
# Copyright 2022-2024 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
|
|
PYTHON_COMPAT=( python3_{11..12} )
|
|
inherit meson vala gnome2-utils python-any-r1
|
|
|
|
MY_PN="SwayNotificationCenter"
|
|
DESCRIPTION="A simple notification daemon with a GTK gui for notifications and control center"
|
|
HOMEPAGE="https://github.com/ErikReider/SwayNotificationCenter"
|
|
SRC_URI="https://github.com/ErikReider/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
|
S="${WORKDIR}/${MY_PN}-${PV}"
|
|
|
|
LICENSE="GPL-3"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64 ~x86"
|
|
IUSE="pulseaudio"
|
|
|
|
DEPEND="
|
|
dev-lang/sassc
|
|
dev-libs/glib:2
|
|
dev-libs/gobject-introspection
|
|
dev-libs/granite:=
|
|
dev-libs/json-glib
|
|
dev-libs/libgee:0.8=
|
|
dev-libs/wayland
|
|
>=gui-libs/gtk-layer-shell-0.8.0[introspection,vala]
|
|
gui-libs/libhandy:1
|
|
sys-apps/dbus
|
|
x11-libs/gdk-pixbuf:2
|
|
x11-libs/gtk+:3
|
|
pulseaudio? ( media-libs/libpulse )
|
|
"
|
|
RDEPEND="
|
|
${DEPEND}
|
|
x11-libs/cairo
|
|
x11-libs/pango
|
|
"
|
|
|
|
BDEPEND="
|
|
${PYTHON_DEPS}
|
|
$(vala_depend)
|
|
app-text/scdoc
|
|
"
|
|
|
|
src_configure() {
|
|
local emesonargs=($(meson_use pulseaudio pulse-audio))
|
|
meson_src_configure
|
|
}
|
|
|
|
src_prepare() {
|
|
default
|
|
vala_setup
|
|
}
|
|
|
|
pkg_postinst() {
|
|
gnome2_schemas_update
|
|
}
|
|
|
|
pkg_postrm() {
|
|
gnome2_schemas_update
|
|
}
|