guru/gui-apps/corehunt/corehunt-9999.ebuild
Takuya Wakazono 13f7f0d209
gui-apps/corehunt: add 4.5.0, live sync
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
2024-01-13 20:59:33 +09:00

30 lines
636 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit xdg cmake
DESCRIPTION="A file finder utility for C Suite"
HOMEPAGE="https://gitlab.com/cubocore/coreapps/corehunt"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/corehunt.git"
else
SRC_URI="https://gitlab.com/cubocore/coreapps/corehunt/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${PV}"
fi
LICENSE="GPL-3"
SLOT="0"
DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
gui-libs/libcprime
"
RDEPEND="${DEPEND}"