guru/dev-games/surgescript/surgescript-0.5.5.ebuild
Anna (cybertailor) Vyalkova bb0aae8ad3
*/*: disable py3.10
Python 3.10 target is scheduled for removal in Gentoo:
https://public-inbox.gentoo.org/gentoo-dev/e6ca9f1f4ababb79ab2a3d005c39b483c3ecef6e.camel@gentoo.org/

Sphinx 8.2.0 already dropped support for CPython 3.10 and PyPy 3.10,
leading to multiple CI failures in ::guru.

We can safely remove this target, because GURU is "experimental" and
does not have stable keywords.

Let's not remove "pypy3" right now because
a) There are not many packages using it.
b) So we can see which packages supported PyPy 3.10, and test them with
   PyPy 3.11.

Closes: https://github.com/gentoo/guru/pull/291
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
2025-02-21 17:51:14 +05:00

54 lines
1.0 KiB
Bash

# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{11..12} )
DOCS_BUILDER="mkdocs"
DOCS_DEPEND="dev-python/mkdocs-material"
inherit cmake python-any-r1 docs
DESCRIPTION="scripting language made for opensurge"
HOMEPAGE="https://alemart.github.io/surgescript"
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/alemart/${PN}.git"
SLOT="0"
else
SRC_URI="https://github.com/alemart/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
SLOT="0/$(ver_cut 1-3)"
fi
LICENSE="Apache-2.0"
IUSE="examples static-libs"
DOCS=( CHANGES.md README.md )
src_prepare() {
cmake_src_prepare
sed -i -e '/^strict: true$/d' -e '/^google_analytics/d' mkdocs.yml || die
}
src_configure() {
local mycmakeoptions=(
-DWANT_STATIC=$(usex static-libs)
)
cmake_src_configure
}
src_compile() {
cmake_src_compile
docs_compile
}
src_install() {
cmake_src_install
docompress -x /usr/share/doc/${PF}/examples
use examples && dodoc -r examples
}