guru/dev-crystal/inflector/inflector-1.0.0.ebuild
Anna (cybertailor) Vyalkova cfeb655d90
dev-crystal/inflector: new package, add 1.0.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
2022-11-09 00:03:33 +05:00

24 lines
478 B
Bash

# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit shards
MY_PN="${PN}.cr"
DESCRIPTION="String inflectors for Crystal"
HOMEPAGE="https://github.com/phoffer/inflector.cr"
SRC_URI="https://github.com/phoffer/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
src_prepare() {
default
# test error
rm spec/inflector_spec.cr || die
}