guru/app-text/lchat/lchat-1.0-r2.ebuild
Carlos Eduardo bbf25b4f27
app-text/lchat: respect LDFLAGS 2.0
Closes: https://bugs.gentoo.org/932604
Signed-off-by: Carlos Eduardo <carana2099@gmail.com>
2024-05-30 07:07:16 -03:00

31 lines
705 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Line oriented front end for ii-like chat programs"
HOMEPAGE="https://tools.suckless.org/lchat/"
SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="dev-libs/libgrapheme"
DEPEND="${RDEPEND}"
IUSE="+examples"
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="$CFLAGS" LIBS="-lgrapheme $LDFLAGS" all
if use examples; then
emake CC="$(tc-getCC)" CFLAGS="$CFLAGS $LDFLAGS" filter/indent
fi
}
src_install() {
doman lchat.1
dobin lchat
mv filter/indent lchat-indent
use examples && dobin lchat-indent
}