mirror of
https://github.com/gentoo-mirror/guru.git
synced 2025-04-18 07:19:01 -04:00
Python 3.10 target is scheduled for removal in Gentoo: https://public-inbox.gentoo.org/gentoo-dev/e6ca9f1f4ababb79ab2a3d005c39b483c3ecef6e.camel@gentoo.org/ Sphinx 8.2.0 already dropped support for CPython 3.10 and PyPy 3.10, leading to multiple CI failures in ::guru. We can safely remove this target, because GURU is "experimental" and does not have stable keywords. Let's not remove "pypy3" right now because a) There are not many packages using it. b) So we can see which packages supported PyPy 3.10, and test them with PyPy 3.11. Closes: https://github.com/gentoo/guru/pull/291 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
28 lines
684 B
Bash
28 lines
684 B
Bash
# Copyright 1999-2022 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
|
|
PYTHON_COMPAT=( python3_11 pypy3 )
|
|
DISTUTILS_USE_PEP517=setuptools
|
|
PYTHON_REQ_USE="ncurses(+)"
|
|
inherit distutils-r1 optfeature
|
|
|
|
DESCRIPTION="Countdown timer and stopwatch in your terminal"
|
|
HOMEPAGE="https://github.com/trehn/termdown"
|
|
SRC_URI="https://github.com/trehn/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
|
|
|
|
LICENSE="GPL-3"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64"
|
|
|
|
RDEPEND="
|
|
dev-python/click[${PYTHON_USEDEP}]
|
|
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
|
dev-python/pyfiglet[${PYTHON_USEDEP}]
|
|
"
|
|
|
|
pkg_postinst() {
|
|
optfeature "spoken countdown" app-accessibility/espeak-ng
|
|
}
|