mirror of
https://github.com/gentoo-mirror/guru.git
synced 2025-04-19 15:59:00 -04:00
36 lines
999 B
Bash
36 lines
999 B
Bash
# Copyright 1999-2025 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
PYTHON_COMPAT=(python3_{11..13})
|
|
# certbot ready for 3.13, but not cloudflare
|
|
#DISTUTILS_USE_SETUPTOOLS=rdepend
|
|
DISTUTILS_USE_PEP517=setuptools
|
|
|
|
MYPN="certbot"
|
|
|
|
if [[ ${PV} == 9999* ]]; then
|
|
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
|
|
inherit git-r3
|
|
S=${WORKDIR}/${P}/${PN}
|
|
else
|
|
SRC_URI="https://github.com/certbot/${MYPN}/archive/v${PV}.tar.gz -> ${MYPN}-${PV}.gh.tar.gz"
|
|
KEYWORDS="~amd64"
|
|
S=${WORKDIR}/certbot-${PV}/${PN}
|
|
fi
|
|
|
|
inherit distutils-r1
|
|
|
|
DESCRIPTION="Cloudflare DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
|
|
HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
|
|
|
|
LICENSE="Apache-2.0"
|
|
SLOT="0"
|
|
|
|
RDEPEND="${CDEPEND}
|
|
>=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
|
|
=dev-python/cloudflare-2.19*[${PYTHON_USEDEP}]"
|
|
BDEPEND="test? ( ${RDEPEND} )"
|
|
distutils_enable_tests pytest
|
|
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
|