gentoo-zh/net-misc/uuplugin/uuplugin-4.14.4.ebuild
jinqiang zhang 31305386d4 net-misc/uuplugin: update SRC_URI
Signed-off-by: jinqiang zhang <jinqiang@zhang.my>
2024-11-09 11:27:15 +08:00

27 lines
559 B
Bash

# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit systemd
DESCRIPTION="UU Game Accelerator for Linux"
HOMEPAGE="https://uu.163.com/"
SRC_URI="https://uu.gdl.netease.com/uuplugin/steam-deck-plugin-x86_64/v${PV}/uu.tar.gz -> ${P}.tar.gz"
S=${WORKDIR}
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64"
RESTRICT="mirror strip bindist"
QA_PREBUILT="usr/bin/uuplugin"
src_install() {
dobin uuplugin
insinto /etc/uuplugin
doins uu.conf
systemd_dounit "${FILESDIR}/uuplugin.service"
}