gentoo-zh/dev-cpp/reproc/reproc-14.2.5.ebuild
jinqiang zhang 00fdfd6cdc dev-cpp/reproc: add 14.2.5, drop 14.2.4
Signed-off-by: jinqiang zhang <jinqiang@zhang.my>
2024-11-08 13:09:59 +08:00

29 lines
670 B
Bash

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake-multilib
DESCRIPTION="A cross-platform (C99/C++11) process library"
HOMEPAGE="https://github.com/DaanDeMeyer/reproc"
SRC_URI="https://github.com/DaanDeMeyer/reproc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/14"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="test"
RESTRICT="test"
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_BUILD_TYPE=Release
-DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
-DCMAKE_INSTALL_LIBDIR=$(get_libdir)
-DBUILD_SHARED_LIBS=ON
-DREPROC++=ON
-DREPROC_TEST=$(usex test)
)
cmake_src_configure
}