gentoo-zh/app-crypt/archlinux-keyring/archlinux-keyring-20240208-r1.ebuild
Linerre 30606c68fe sys-apps/pacman: add 6.1.0, drop 6.0.2
Signed-off-by: Linerre <leon.errelin@outlook.com>
2024-03-05 18:08:18 +08:00

34 lines
924 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="GnuPG keyring of Archlinux developer keys"
HOMEPAGE="https://gitlab.archlinux.org/archlinux/archlinux-keyring"
#SRC_URI="https://sources.archlinux.org/other/${PN}/${P}.tar.gz"
SRC_URI="https://gitlab.archlinux.org/archlinux/${PN}/-/archive/${PV}/${P}.tar.bz2"
LICENSE="GPL-2" # "GPL" for the Arch linux package
SLOT="0"
KEYWORDS="~amd64"
PATCHES="${FILESDIR}/01_adapt_to_sequoia_sq_0_34.patch"
BDEPEND=">=app-crypt/sequoia-sq-0.33.0"
src_compile(){
emake build
}
src_install(){
emake PREFIX='/usr' DESTDIR="${D}" install
}
pkg_postinst() {
einfo ""
einfo "This package only installs the keyring files while sys-apps/pacman"
einfo "initializes these keyrings to actually use it. This is a different"
einfo "behaviour from Archlinux, but is necessary to avoid circular deps."
einfo ""
}