mirror of
https://github.com/gentoo-mirror/gentoo-zh.git
synced 2025-04-19 07:48:56 -04:00
media-libs/libva-nvidia-driver: treeclean
This commit is contained in:
parent
db0ee4c5ff
commit
d16ed029f0
@ -1 +0,0 @@
|
||||
DIST libva-nvidia-driver-0.0.9.tar.gz 182169 BLAKE2B 8bdc55d22bcb2903bf8bfcccffc10b4183d0694378ff094e123247cb4a97da6bd182dccee8439f0e5c0f14ba96f0d9182822ef5171006358800d1a6a60822a4b SHA512 408e0421b0a4d960b701e45cc2fb73fa6e6458140d01b1f84db01bbfed6a2721cb14af0807ebf098cec5e80a0f778762d81dedb0e7fab42b7348cf13ce1d472e
|
@ -1,25 +0,0 @@
|
||||
From e0831828a438003f8a86b5d2b4026c1cb8f48efe Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Udvare <audvare@gmail.com>
|
||||
Date: Tue, 25 Jan 2022 23:19:21 -0500
|
||||
Subject: [PATCH] Set correct install path
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 9d9fc84..e31c36b 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -47,7 +47,7 @@ shared_library(
|
||||
dl_dep,
|
||||
],
|
||||
install: true,
|
||||
- install_dir: get_option('libdir') / 'dri',
|
||||
+ install_dir: get_option('libdir') / 'va' / 'drivers',
|
||||
gnu_symbol_visibility: 'hidden',
|
||||
)
|
||||
|
||||
--
|
||||
2.35.0
|
||||
|
@ -1 +0,0 @@
|
||||
libva-nvidia-driver-9999.ebuild
|
@ -1,41 +0,0 @@
|
||||
# Copyright 2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DESCRIPTION="NVDEC Backend for Video Acceleration (VA) API"
|
||||
HOMEPAGE="https://github.com/elFarto/nvidia-vaapi-driver"
|
||||
|
||||
if [[ ${PV} != *9999* ]] ; then
|
||||
EGIT_COMMIT=v${PV}
|
||||
KEYWORDS="~amd64"
|
||||
SRC_URI="https://github.com/elFarto/nvidia-vaapi-driver/archive/v${PV}/libva-nvidia-driver-${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
S="${WORKDIR}/nvidia-vaapi-driver-${PV}"
|
||||
else
|
||||
EGIT_REPO_URI="https://github.com/elFarto/nvidia-vaapi-driver.git"
|
||||
inherit git-r3
|
||||
fi
|
||||
|
||||
inherit meson
|
||||
|
||||
RESTRICT="mirror"
|
||||
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
|
||||
RDEPEND="
|
||||
>=media-libs/libva-2.16
|
||||
>=media-libs/gstreamer-1.0
|
||||
>=media-libs/gst-plugins-bad-1.0
|
||||
>=media-libs/libglvnd-1.6.0
|
||||
"
|
||||
|
||||
DEPEND="${RDEPEND}"
|
||||
BDEPEND="virtual/pkgconfig
|
||||
>=media-libs/nv-codec-headers-11.1.5.1
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/01-install-path.patch"
|
||||
)
|
@ -1,8 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<!-- maintainer-needed -->
|
||||
<upstream>
|
||||
<remote-id type="github">elFarto/nvidia-vaapi-driver</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user