net-p2p/mldonkey: fix indirect link to libpng problem

see bug #432772, #435430

Signed-off-by: Lan Yixun (dlan) <dennis.yxun@gmail.com>
This commit is contained in:
Lan Yixun (dlan) 2013-01-17 13:01:47 +08:00
parent 594fd806fb
commit c1d9c1dbba
3 changed files with 15 additions and 1 deletions

View File

@ -0,0 +1,13 @@
diff --git a/config/Makefile.in b/config/Makefile.in
index e10cadf..9659e06 100644
--- a/config/Makefile.in
+++ b/config/Makefile.in
@@ -554,7 +554,7 @@ CORE_SRCS += $(OPENFT_SRCS)
endif
ifeq ("$(GD)", "yes")
- GD_LIBS_flags=-cclib "-lgd $(GD_LIBS)" -ccopt "$(GD_LDFLAGS)"
+ GD_LIBS_flags=-cclib "-lgd -lpng $(GD_LIBS)" -ccopt "$(GD_LDFLAGS)"
ifneq ("$(GD_STATIC_LIBS)", "")
GD_STATIC_LIBS_opt=-cclib "-lgd $(GD_STATIC_LIBS)" -ccopt "$(GD_LDFLAGS)"
endif

View File

@ -53,7 +53,8 @@ pkg_setup() {
}
src_prepare() {
epatch "${FILESDIR}/${PN}-gcc.patch"
epatch "${FILESDIR}/${P}-gcc.patch"
epatch "${FILESDIR}/${P}-png.patch"
epatch_user
cd "${S}"/config
eautoconf