mirror of
https://github.com/gentoo-mirror/gentoo-zh.git
synced 2025-04-04 01:18:31 -04:00
app-crypt/cfssl: treeclean
Signed-off-by: jinqiang zhang <jinqiang@zhang.my>
This commit is contained in:
parent
8166076fc1
commit
ad910cfc26
7
.github/workflows/overlay.toml
vendored
7
.github/workflows/overlay.toml
vendored
@ -58,13 +58,6 @@ gitlab = "archlinux/archlinux-keyring"
|
||||
use_max_tag = true
|
||||
github_account = "HougeLangley"
|
||||
|
||||
["app-crypt/cfssl"]
|
||||
source = "github"
|
||||
github = "cloudflare/cfssl"
|
||||
use_latest_release = true
|
||||
prefix = "v"
|
||||
github_account = "peeweep"
|
||||
|
||||
["app-dicts/fcitx-pinyin-moegirl"]
|
||||
source = "github"
|
||||
github = "outloudvi/mw2fcitx"
|
||||
|
@ -1 +0,0 @@
|
||||
DIST cfssl-1.6.5.tar.gz 8164981 BLAKE2B e82a80969f1b51142753bb9a8fcd4ec4854eb3a456bc1170159117ca8a29d6cb883c25e37981e7922f91480e161b1d0eea0c5265caaa550ccf31e01b092dac8b SHA512 b59863d534474ba73efe2dc38b55ba4eb1e0911346b6b9fff7778a3bdc77bf58290ab7173e3ce2cd69f38594dc471ce78632c2aa1cf9188eb6163ca272391185
|
@ -1,33 +0,0 @@
|
||||
# Copyright 1999-2024 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit go-module
|
||||
|
||||
DESCRIPTION="Cloudflare's PKI and TLS toolkit"
|
||||
HOMEPAGE="https://github.com/cloudflare/cfssl"
|
||||
SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm64"
|
||||
IUSE="hardened"
|
||||
|
||||
RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-1.4.1-build-fix.patch"
|
||||
)
|
||||
|
||||
src_compile() {
|
||||
# bug 905997
|
||||
use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
|
||||
|
||||
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
dobin bin/*
|
||||
dodoc CHANGELOG README.md
|
||||
}
|
@ -1,16 +0,0 @@
|
||||
This patch cannot be upstreamed in this form. However, the following
|
||||
issue has been opened to discuss integrating a better solution upstream.
|
||||
|
||||
https://github.com/cloudflare/cfssl/issues/1062
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 10a52fc..7fc019b 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,5 +1,4 @@
|
||||
-VERSION := $(shell git describe --tags --abbrev=0 | tr -d '[:alpha:]')
|
||||
-LDFLAGS := "-s -w -X github.com/cloudflare/cfssl/cli/version.version=$(VERSION)"
|
||||
+LDFLAGS := "-X github.com/cloudflare/cfssl/cli/version.version=$(VERSION)"
|
||||
|
||||
export GOFLAGS := -mod=vendor
|
||||
export GOPROXY := off
|
@ -1,11 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>williamh@gentoo.org</email>
|
||||
<name>William Hubbs</name>
|
||||
</maintainer>
|
||||
<upstream>
|
||||
<remote-id type="github">cloudflare/cfssl</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user