media-sound/netease-cloud-music-gtk: make isahc use system curl

This commit is contained in:
G-Src 2025-01-08 19:33:20 +08:00 committed by peeweep
parent 7108272318
commit 97703d2277
2 changed files with 17 additions and 0 deletions

View File

@ -0,0 +1,13 @@
diff --git a/Cargo.toml b/Cargo.toml
index 27f8d74..491fac0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,7 +6,7 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-isahc = { version = "^1", features = ["cookies"] }
+isahc = { version = "^1", default-features = false, features = ["cookies", "http2", "text-decoding"] }
lazy_static = "*"
regex = "*"
urlqstring = "*"

View File

@ -386,6 +386,10 @@ src_prepare() {
sed -i -E "s#${ncm_api_git}#${ncm_api_path}#g" "${S}/Cargo.toml" || die "ncm-api workaround failed"
pushd "${WORKDIR}/netease-cloud-music-api-${NCM_API_COMMIT}" > /dev/null || die
eapply "${FILESDIR}/isahc-disable-static-curl.patch"
popd > /dev/null || die
default
}