net-proxy/daed: add 0.6.0, drop 0.4.1

Signed-off-by: liuyujielol <2073201758GD@gmail.com>
This commit is contained in:
liuyujielol 2024-06-23 22:56:20 +08:00 committed by 梁永祥
parent 8495ee62b0
commit 8d21742e4e
3 changed files with 14 additions and 24 deletions

View File

@ -1,2 +1,2 @@
DIST daed-0.4.1-node_modules-pnpm.tar.xz 76723904 BLAKE2B 23a518f8ee1a94d9f95f050644dbfc94cf741ca803dcabe9adce8baf99f4f2087ca156c88444de75c52e31c74243d4e102226ffc024918027c2cc593453a98e3 SHA512 aeb0d32f985f0af08d48a4085a43d3b94a21f4b4a4c2d17663fa08b67014e592349c9b509a8649475b3c6d7df1b4b19ab2ed5bd60098ea3cd41c8158897f74de
DIST daed-0.4.1.zip 144610383 BLAKE2B d23fabd77e7998dbbe97ca766504c5799d30e0b82adbbb7f5caeb5f0fccf5f3ba9ca204f88b6fb2498028c2d04387eb2915fdd46088bf86d1fa99a4da4c85348 SHA512 b137a82e2469e5c68c4a1c6d19c6fd1f55d56d49103296c69ac89b3154e0bd57045e649ba90aac724a406c5b21370fcb52edc045bf9bcd59fedd59250251596d
DIST daed-0.6.0-web.zip 5131293 BLAKE2B fe444fddb44a60174d458f8ad49a3c8351c7acd8329d95746780ea5ab5ba501e16cb28651370ade0592c6c44cd9eb53110f60ac1893149cd19b8f1909e4d7766 SHA512 6b6606cad45ad414d7d316bc3c8fb2227d587ee72023cc5ebb57587015a3a8616d3c5d0d3e8a7acdd7948e6ccb83d93927e0395369ef5bcbb44c7c820f30edc3
DIST daed-0.6.0.zip 144592837 BLAKE2B 15d051f8cca9689e3e71e8c9623fc74c617722e01c04291a25add7717ef41bac829878fafea41e32f890eeabc7b6ce3dbadf69d2e335f046b50f74549b1a8b3f SHA512 ec2902a794fa25a1ec3d371c97c97e3d66c097728a789b83a6687fb42e0a6af6cdcccae1281a8e88c1e5978ef1a2054f166a9a277e3d9b87baeb7e20d83104dd

View File

@ -1,4 +1,4 @@
# Copyright 2023 Gentoo Authors
# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@ -9,7 +9,7 @@ DESCRIPTION="A Modern Dashboard For dae"
HOMEPAGE="https://github.com/daeuniverse/daed"
SRC_URI="
https://github.com/daeuniverse/daed/releases/download/v${PV/_rc/rc}/daed-full-src.zip -> ${P}.zip
webui? ( https://github.com/st0nie/gentoo-go-deps/releases/download/${P}/${P}-node_modules-pnpm.tar.xz )
webui? ( https://github.com/daeuniverse/daed/releases/download/v${PV/_rc/rc}/web.zip -> ${P}-web.zip )
"
# EGIT_REPO_URI="https://github.com/daeuniverse/daed.git"
@ -24,7 +24,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
webui? ( net-libs/nodejs[npm] )
sys-devel/clang
app-arch/unzip
dev-lang/go
@ -34,9 +33,14 @@ RESTRICT="strip"
src_prepare() {
# Prevent conflicting with the user's flags
# https://devmanual.gentoo.org/ebuild-writing/common-mistakes/#-werror-compiler-flag-not-removed
sed -i -e 's/-Werror//' wing/dae-core/Makefile || die 'Failed to remove -Werror via sed'
eapply "${FILESDIR}"/pnpm_fix.patch
if use webui; then
# Use upstream web archive
sed -e 's|daed: submodule $(DAE_WING_READY) dist|daed: $(DAE_WING_READY)|' \
-i Makefile || die
mv -v "${WORKDIR}/web" "${S}/dist" || die
fi
default
}
@ -59,11 +63,11 @@ src_install(){
local service=install/daed.service
if use webui; then
dobin daed
systemd_dounit $service
systemd_dounit ${service}
else
dobin wing/dae-wing
sed -i "s!/usr/bin/daed!/usr/bin/dae-wing!" $service || die
systemd_newunit $service dae-wing.service
sed -i "s!/usr/bin/daed!/usr/bin/dae-wing!" ${service} || die
systemd_newunit ${service} dae-wing.service
fi
keepdir /etc/daed/
dosym -r "/usr/share/v2ray/geosite.dat" /usr/share/daed/geosite.dat

View File

@ -1,14 +0,0 @@
diff --git a/Makefile b/Makefile
index 72fbba5..4554e12 100644
--- a/Makefile
+++ b/Makefile
@@ -41,8 +41,7 @@ ifeq (,$(wildcard ./.git))
PFLAGS += HUSKY=0
endif
dist: package.json pnpm-lock.yaml
- $(PFLAGS) pnpm i
- pnpm build
+ npm run build
## End Web
## Begin Bundle