mirror of
https://github.com/gentoo-mirror/gentoo-zh.git
synced 2025-04-10 20:08:43 -04:00
gui-apps/crystal-dock: new package, add 2.7
Signed-off-by: liuyujielol <2073201758GD@gmail.com>
This commit is contained in:
parent
94bb653500
commit
887f6ae790
7
.github/workflows/overlay.toml
vendored
7
.github/workflows/overlay.toml
vendored
@ -725,6 +725,13 @@ source = "regex"
|
||||
url = "https://winegame.net/downloads/"
|
||||
regex = "net.winegame.client_([\\d.]+)_amd64.deb"
|
||||
|
||||
["gui-apps/crystal-dock"]
|
||||
source = "github"
|
||||
github = "dangvd/crystal-dock"
|
||||
prefix = "v"
|
||||
use_latest_release = true
|
||||
github_account = "liuyujielol"
|
||||
|
||||
["gui-libs/libdecor"]
|
||||
source = "gitlab"
|
||||
host = "gitlab.freedesktop.org"
|
||||
|
1
gui-apps/crystal-dock/Manifest
Normal file
1
gui-apps/crystal-dock/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST crystal-dock-2.7.tar.gz 1937925 BLAKE2B d9a1a56077558807805933bd94ddaced9c7653719bbe5b7a8fcbff1e15363c4e3c6d0455fe1750e85da2417a2b593d4d3692e5cd4caab35caf53e99c014718f0 SHA512 2f3903f183d4df3b920f1bcd5fe5fc7eef7007847e9ee759e7e8565fe8cf8de27070ad6c43e17877e521be6a30b56f8bfc1010c0719ec1f605046a52b1d67738
|
30
gui-apps/crystal-dock/crystal-dock-2.7.ebuild
Normal file
30
gui-apps/crystal-dock/crystal-dock-2.7.ebuild
Normal file
@ -0,0 +1,30 @@
|
||||
# Copyright 2024 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
inherit cmake xdg
|
||||
|
||||
DESCRIPTION="Cool dock (desktop panel) for Linux desktop"
|
||||
HOMEPAGE="https://github.com/dangvd/crystal-dock"
|
||||
SRC_URI="
|
||||
https://github.com/dangvd/crystal-dock/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
|
||||
"
|
||||
S="${WORKDIR}/${P}/src"
|
||||
|
||||
LICENSE="GPL-3"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
DEPEND="
|
||||
>=dev-libs/wayland-1.22
|
||||
dev-qt/qtbase:6[dbus,gui,widgets]
|
||||
dev-util/vulkan-headers
|
||||
kde-plasma/layer-shell-qt:6
|
||||
x11-libs/libxkbcommon
|
||||
"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
# From upstream, remove on next bump
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-static_lib.patch"
|
||||
)
|
@ -0,0 +1,20 @@
|
||||
From upstream
|
||||
Sets crystal-dock_lib to STATIC explicitly to avoid unresolved soname.
|
||||
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 0c1e5ae..33d3c3f 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -91,7 +91,7 @@ set(SRCS
|
||||
view/edit_launchers_dialog.ui
|
||||
view/task_manager_settings_dialog.ui
|
||||
view/wallpaper_settings_dialog.ui)
|
||||
-add_library(crystal-dock_lib ${SRCS})
|
||||
+add_library(crystal-dock_lib STATIC ${SRCS})
|
||||
|
||||
set(LIBS Qt6::DBus Qt6::GuiPrivate Qt6::Widgets Wayland::Client LayerShellQt::Interface stdc++fs)
|
||||
target_link_libraries(crystal-dock_lib ${LIBS})
|
11
gui-apps/crystal-dock/metadata.xml
Normal file
11
gui-apps/crystal-dock/metadata.xml
Normal file
@ -0,0 +1,11 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>2073201758GD@gmail.com</email>
|
||||
<name>liuyujielol</name>
|
||||
</maintainer>
|
||||
<upstream>
|
||||
<remote-id type="github">dangvd/crystal-dock</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user