diff --git a/dev-libs/cpr/Manifest b/dev-libs/cpr/Manifest
new file mode 100644
index 000000000..427c53cbc
--- /dev/null
+++ b/dev-libs/cpr/Manifest
@@ -0,0 +1 @@
+DIST cpr-1.11.2.tar.gz 143182 BLAKE2B fa881dd47128d632b9c939007ede8ad52e4c1d3eec72d3831fe51376a58be945fe1e774bf202bcb5818c6494bdc3a538b08ef2062fd9500fd128f1361cb0379d SHA512 30caf9257e5e45f809f541a32daf8c6c7001fbaafef0ee0ae8dd59f49736953120cb7c8849ddbff2f7fbc54d80902ec2b905f90f68f63d1f2a2dc63eda577713
diff --git a/dev-libs/cpr/cpr-1.11.2.ebuild b/dev-libs/cpr/cpr-1.11.2.ebuild
new file mode 100644
index 000000000..f0fc50403
--- /dev/null
+++ b/dev-libs/cpr/cpr-1.11.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ Requests: Curl for People, a spiritual port of Python Requests."
+HOMEPAGE="https://github.com/libcpr/cpr"
+SRC_URI="https://github.com/libcpr/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+ssl mbedtls"
+
+DEPEND="net-misc/curl
+ dev-cpp/gtest
+ mbedtls? ( net-libs/mbedtls )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPR_USE_SYSTEM_CURL=ON
+ -DCPR_USE_SYSTEM_GTEST=ON
+ -DBUILD_SHARED_LIBS=ON
+ -DCPR_ENABLE_SSL=$(usex ssl)
+ -DCPR_FORCE_MBEDTLS_BACKEND=$(usex mbedtls)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/cpr/metadata.xml b/dev-libs/cpr/metadata.xml
new file mode 100644
index 000000000..0ffe5390a
--- /dev/null
+++ b/dev-libs/cpr/metadata.xml
@@ -0,0 +1,15 @@
+
+
+
+
+ gsrc@fsfans.club
+ G-Src
+
+
+
+ libcpr/cpr
+ https://github.com/libcpr/cpr/issues
+
+
diff --git a/net-proxy/nekobox-core/Manifest b/net-proxy/nekobox-core/Manifest
new file mode 100644
index 000000000..f6e1b9a49
--- /dev/null
+++ b/net-proxy/nekobox-core/Manifest
@@ -0,0 +1,2 @@
+DIST nekobox-core-4.2.12-deps.tar.xz 81924268 BLAKE2B 7b9aca9c59588d3d27c201110a4dc27f243468ef7f8ab350ab1e12b6cd09ca1ef8dc1d456f1415b0393948f27705a5ca30aff5d2d43b66bafc79a24ca8918e12 SHA512 813562409329bf83173c530f060f95a844da18da562022d6da1d3c5cee3154bb6f317d2b8e0383d4327c576ee4f263bc2a977c849e4510c6134687e426b6f01b
+DIST nekobox-core-4.2.12.tar.gz 580047 BLAKE2B 83d1607dbc47c84b23457db5695553a1b9721c45eaad04b82bc66c4f74f0bfe479d6a7d178bf11b18661556331f667d68806c090ecd1b83b73f0d7a175b3d2d4 SHA512 ced86c324cff4a235ee4a386c6892e1814b231f9a70dbb10b51abbe646e3c3476614fc4407d8316ed37675383aca5d7fe327759142f52bf56d2c181aec816d1c
diff --git a/net-proxy/nekobox-core/metadata.xml b/net-proxy/nekobox-core/metadata.xml
new file mode 100644
index 000000000..50aa99155
--- /dev/null
+++ b/net-proxy/nekobox-core/metadata.xml
@@ -0,0 +1,12 @@
+
+
+
+
+ gsrc@fsfans.club
+ G-Src
+
+
+ Mahdi-zarei/nekoray
+ G-two/vendor
+
+
diff --git a/net-proxy/nekobox-core/nekobox-core-4.2.12.ebuild b/net-proxy/nekobox-core/nekobox-core-4.2.12.ebuild
new file mode 100644
index 000000000..769b542a0
--- /dev/null
+++ b/net-proxy/nekobox-core/nekobox-core-4.2.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Qt based Desktop cross-platform GUI proxy configuration manager"
+HOMEPAGE="https://github.com/Mahdi-zarei/nekoray"
+SRC_URI="https://github.com/Mahdi-zarei/nekoray/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://codeberg.org/G-two/vendor/raw/branch/main/${P}-deps.tar.xz"
+
+S="${WORKDIR}/nekoray-${PV}/core/server"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build \
+ -tags "with_clash_api,with_gvisor,with_quic,with_wireguard,with_utls,with_ech,with_dhcp" \
+ -ldflags "-X 'github.com/sagernet/sing-box/constant.Version=${PV}'"
+}
+
+src_install() {
+ exeinto /usr/lib/nekoray/
+ doexe nekobox_core
+}
diff --git a/net-proxy/nekoray/Manifest b/net-proxy/nekoray/Manifest
new file mode 100644
index 000000000..9b65b4efa
--- /dev/null
+++ b/net-proxy/nekoray/Manifest
@@ -0,0 +1 @@
+DIST nekoray-4.2.12.tar.gz 580047 BLAKE2B 83d1607dbc47c84b23457db5695553a1b9721c45eaad04b82bc66c4f74f0bfe479d6a7d178bf11b18661556331f667d68806c090ecd1b83b73f0d7a175b3d2d4 SHA512 ced86c324cff4a235ee4a386c6892e1814b231f9a70dbb10b51abbe646e3c3476614fc4407d8316ed37675383aca5d7fe327759142f52bf56d2c181aec816d1c
diff --git a/net-proxy/nekoray/files/nekoray.desktop b/net-proxy/nekoray/files/nekoray.desktop
new file mode 100644
index 000000000..cd8fd67df
--- /dev/null
+++ b/net-proxy/nekoray/files/nekoray.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Terminal=false
+Type=Application
+Name=NekoRay
+Categories=Network;
+Comment=Qt based cross-platform GUI proxy configuration manager (backend: sing-box)
+Comment[zh_CN]=基于 Qt 的跨平台代理配置管理器 (后端 sing-box)
+Keywords=Internet;VPN;Proxy;sing-box;
+Exec=nekoray
+Icon=nekobox
diff --git a/net-proxy/nekoray/files/nekoray.sh b/net-proxy/nekoray/files/nekoray.sh
new file mode 100644
index 000000000..e1bfcbf7f
--- /dev/null
+++ b/net-proxy/nekoray/files/nekoray.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+exec /usr/lib/nekoray/nekoray -appdata "$@"
diff --git a/net-proxy/nekoray/metadata.xml b/net-proxy/nekoray/metadata.xml
new file mode 100644
index 000000000..3bb4b184f
--- /dev/null
+++ b/net-proxy/nekoray/metadata.xml
@@ -0,0 +1,11 @@
+
+
+
+
+ gsrc@fsfans.club
+ G-Src
+
+
+ Mahdi-zarei/nekoray
+
+
diff --git a/net-proxy/nekoray/nekoray-4.2.12.ebuild b/net-proxy/nekoray/nekoray-4.2.12.ebuild
new file mode 100644
index 000000000..f15c37327
--- /dev/null
+++ b/net-proxy/nekoray/nekoray-4.2.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg desktop
+
+DESCRIPTION="Qt based Desktop cross-platform GUI proxy configuration manager"
+HOMEPAGE="https://github.com/Mahdi-zarei/nekoray"
+SRC_URI="https://github.com/Mahdi-zarei/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-cpp/abseil-cpp
+ dev-libs/protobuf:=
+ dev-libs/cpr
+ dev-qt/qtbase:6[widgets,network]
+ dev-cpp/yaml-cpp
+ media-libs/zxing-cpp
+ net-proxy/nekobox-core"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-qt/qttools:6[linguist]
+ dev-util/patchelf"
+
+src_install() {
+ exeinto "/usr/lib/${PN}/"
+ doexe "${BUILD_DIR}"/nekoray
+ patchelf --replace-needed libqhotkey.so.0 /usr/lib/"${PN}"/libqhotkey.so.0.1 "${ED}"/usr/lib/"${PN}"/nekoray || die
+ newbin "${FILESDIR}"/"${PN}".sh "${PN}"
+ doexe "${BUILD_DIR}"/libqhotkey.so.0.1
+ doicon res/public/nekobox.png
+ domenu "${FILESDIR}"/nekoray.desktop
+}