remove EAPI broken pkg

This commit is contained in:
dr 2020-01-12 20:48:25 +08:00
parent 4e257d7290
commit 7dcd698fb8
29 changed files with 6 additions and 979 deletions

View File

@ -4,7 +4,7 @@
EAPI=7
inherit cmake-utils multilib versionator toolchain-funcs
inherit cmake-utils multilib toolchain-funcs
DESCRIPTION="Rime Input Method Engine library"
HOMEPAGE="http://code.google.com/p/rimeime/"

View File

@ -1,39 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit cmake-utils git-r3
DESCRIPTION="Rime Input Method Engine library"
HOMEPAGE="http://rime.im/"
EGIT_REPO_URI="https://github.com/rime/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="static-libs test"
RDEPEND="
>=app-i18n/opencc-1.0.2
dev-cpp/glog
>=dev-cpp/yaml-cpp-0.5.0
dev-db/kyotocabinet
dev-libs/leveldb
>=dev-libs/boost-1.46.0
dev-libs/marisa
sys-libs/zlib
x11-proto/xproto"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_build static-libs STATIC)
-DBUILD_DATA=OFF
-DBUILD_SEPARATE_LIBS=OFF
$(cmake-utils_use_build test TEST)
-DLIB_INSTALL_DIR=/usr/$(get_libdir)
)
cmake-utils_src_configure
}

View File

@ -1 +0,0 @@
DIST FoxitReader.enu.setup.2.4.4.0911.x64.run.tar.gz 73825236 SHA512 3d37c6606abf31ee0e6db5818ae6526db6c176956d277d6e53b8286c257c7489935f05169dcdb48600c3ce79f4876979fe1571b26539c2b34559300bd8160614

View File

@ -1,22 +0,0 @@
[Desktop Entry]
Encoding=UTF-8
Version=1.0
Name=Foxit Reader
Name[zh_CN]=
Name[zh_HK]=
Name[zh_TW]=
GenericName=PDF Reader
GenericName[zh_CN]=PDF
GenericName[zh_HK]=PDF
GenericName[zh_TW]=PDF
Comment=Read PDF Document
Comment[zh_CN]=PDF
Comment[zh_HK]=PDF
Comment[zh_TW]=PDF
Exec=foxitreader %U
Icon=foxitreader
Terminal=false
Type=Application
StartupNotify=true
Categories=Application;Office;Viewer;
MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;

Binary file not shown.

Before

Width:  |  Height:  |  Size: 3.3 KiB

View File

@ -1,99 +0,0 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit eutils fdo-mime versionator
MY_PV1=$(get_major_version)
MY_PV2=$(get_version_component_range 1-2)
DESCRIPTION="A free PDF document viewer, featuring small size, quick startup, and fast page rendering"
HOMEPAGE="https://www.foxitsoftware.cn/downloads/"
SRC_URI="http://101.110.118.70/cdn01.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/2.4/en_us/FoxitReader.enu.setup.${PV}.x64.run.tar.gz"
LICENSE="${PN}"
SLOT="0"
KEYWORDS="amd64 -*"
IUSE=""
RDEPEND="
dev-libs/atk
dev-libs/glib:2
media-libs/freetype:2
net-print/cups
x11-libs/cairo
x11-libs/gtk+:2
x11-libs/pango
"
S="${WORKDIR}/${PN}-extracted"
QA_PRESTRIPPED="/opt/FoxitReader/FoxitReader"
src_unpack(){
local _file
local _line
local _position
unpack ${A};
mkdir ${PN}-installer;
_file="FoxitReader.enu.setup.2.4.4.0911(r057d814).x64.run"
LANG=C grep --only-matching --byte-offset --binary \
--text $'7z\xBC\xAF\x27\x1C' "${_file}" | cut -f1 -d: |
while read _position
do
dd if="${_file}" \
bs=1M iflag=skip_bytes status=none skip=${_position} \
of="${PN}-installer/bin-${_position}.7z"
done
mkdir ${WORKDIR}/${PN}-extracted;
cd ${PN}-installer;
for _file in *.7z
do
7z -bd -bb0 -y x -o${WORKDIR}/${PN}-extracted ${_file} 1>/dev/null 2>&1 || true
done
}
src_compile(){
epatch_user;
# Remove unneeded files
rm "Activation" "Activation.desktop" "Activation.sh" \
"countinstalltion" "countinstalltion.sh" \
"installUpdate" "ldlibrarypath.sh" \
"maintenancetool.sh" "Uninstall.desktop" \
"Update.desktop" "updater" "updater.sh" "postinst" "prerm" "FoxitReader.sh"
find -type d -name ".svn" -exec rm -rf {} +
find -type f -name ".directory" -exec rm -rf {} +
find -type f -name "*~" -exec rm {} +
find -type f -name "libQt5*~" -exec rm {} +
rm -rf lib platforms imageformats/ printsupport/ sqldrivers/ platforminputcontexts/ platformthemes
}
src_install() {
insinto /opt/${PN}
cp -r * ${D}/opt/${PN} || die
insopts -m755
dosym /opt/${PN}/FoxitReader /usr/bin/${PN} || die
doicon "${FILESDIR}"/${PN}.png || die
make_desktop_entry ${PN} ${PN} ${PN} "Application;Office;Viewer;" "MimeType=application/pdf;"
}
pkg_postinst() {
fdo-mime_mime_database_update
fdo-mime_desktop_database_update
}
pkg_postrm() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
}

View File

@ -1,5 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>printing</herd>
</pkgmetadata>

View File

@ -1,152 +0,0 @@
diff -r 23cf2445ee5d autoconf/m4/ax_define_dir.m4
--- /dev/null Thu Jan 01 00:00:00 1970 +0000
+++ b/autoconf/m4/ax_define_dir.m4 Sat Jan 14 10:52:30 2012 +0200
@@ -0,0 +1,49 @@
+# ===========================================================================
+# http://www.gnu.org/software/autoconf-archive/ax_define_dir.html
+# ===========================================================================
+#
+# SYNOPSIS
+#
+# AX_DEFINE_DIR(VARNAME, DIR [, DESCRIPTION])
+#
+# DESCRIPTION
+#
+# This macro sets VARNAME to the expansion of the DIR variable, taking
+# care of fixing up ${prefix} and such.
+#
+# VARNAME is then offered as both an output variable and a C preprocessor
+# symbol.
+#
+# Example:
+#
+# AX_DEFINE_DIR([DATADIR], [datadir], [Where data are placed to.])
+#
+# LICENSE
+#
+# Copyright (c) 2008 Stepan Kasal <kasal@ucw.cz>
+# Copyright (c) 2008 Andreas Schwab <schwab@suse.de>
+# Copyright (c) 2008 Guido U. Draheim <guidod@gmx.de>
+# Copyright (c) 2008 Alexandre Oliva
+#
+# Copying and distribution of this file, with or without modification, are
+# permitted in any medium without royalty provided the copyright notice
+# and this notice are preserved. This file is offered as-is, without any
+# warranty.
+
+#serial 6
+
+AU_ALIAS([AC_DEFINE_DIR], [AX_DEFINE_DIR])
+AC_DEFUN([AX_DEFINE_DIR], [
+ prefix_NONE=
+ exec_prefix_NONE=
+ test "x$prefix" = xNONE && prefix_NONE=yes && prefix=$ac_default_prefix
+ test "x$exec_prefix" = xNONE && exec_prefix_NONE=yes && exec_prefix=$prefix
+dnl In Autoconf 2.60, ${datadir} refers to ${datarootdir}, which in turn
+dnl refers to ${prefix}. Thus we have to use `eval' twice.
+ eval ax_define_dir="\"[$]$2\""
+ eval ax_define_dir="\"$ax_define_dir\""
+ AC_SUBST($1, "$ax_define_dir")
+ AC_DEFINE_UNQUOTED($1, "$ax_define_dir", [$3])
+ test "$prefix_NONE" && prefix=NONE
+ test "$exec_prefix_NONE" && exec_prefix=NONE
+])
diff -r 23cf2445ee5d configure.ac
--- a/configure.ac Fri Jan 13 00:39:56 2012 -0500
+++ b/configure.ac Sat Jan 14 10:52:30 2012 +0200
@@ -134,6 +134,11 @@
CXXFLAGS="$CXXFLAGS -msse2"
fi
+AC_ARG_WITH(extdatadir, AC_HELP_STRING([--with-extdatadir], [Search Songs etc. from the configured DATADIR]), with_extdatadr=$withval, with_extdatadir=no)
+if test "$with_extdatadir" = "yes"; then
+ AX_DEFINE_DIR([EXT_DATADIR], [datadir], [External datadir])
+fi
+
AC_ARG_WITH(prof, AS_HELP_STRING([--with-prof],[Enable profiling]), with_prof=$withval, with_prof=no)
if test "$with_prof" = "yes"; then
test "$DEFAULT_CFLAGS" = "yes" && CFLAGS="$CFLAGS -pg"
diff -r 23cf2445ee5d src/arch/ArchHooks/ArchHooks_Unix.cpp
--- a/src/arch/ArchHooks/ArchHooks_Unix.cpp Fri Jan 13 00:39:56 2012 -0500
+++ b/src/arch/ArchHooks/ArchHooks_Unix.cpp Sat Jan 14 10:52:30 2012 +0200
@@ -269,15 +269,28 @@
* (Deprecated; use rootfs.) */
FILEMAN->Mount( "dir", "/proc", "/proc" );
#endif
+ // Get Lower case product family
+ RString sProductFamily = PRODUCT_FAMILY;
+ sProductFamily.MakeLower();
RString Root;
struct stat st;
+
+#if defined(EXT_DATADIR)
+ // Search folders at EXT_DATADIR
+ RString ext_dir = EXT_DATADIR + RString("/") + sProductFamily;
+ if( !stat(ext_dir + "/Packages", &st) && st.st_mode&S_IFDIR )
+ Root = ext_dir;
+ else if( !stat(ext_dir + "/Songs", &st) && st.st_mode&S_IFDIR )
+ Root = ext_dir;
+#else
if( !stat(sDirOfExecutable + "/Packages", &st) && st.st_mode&S_IFDIR )
Root = sDirOfExecutable;
else if( !stat(sDirOfExecutable + "/Songs", &st) && st.st_mode&S_IFDIR )
Root = sDirOfExecutable;
else if( !stat(RageFileManagerUtil::sInitialWorkingDirectory + "/Songs", &st) && st.st_mode&S_IFDIR )
Root = RageFileManagerUtil::sInitialWorkingDirectory;
+#endif
else
RageException::Throw( "%s", COULDNT_FIND_SONGS.GetValue().c_str() );
diff -r 23cf2445ee5d src/arch/LoadingWindow/LoadingWindow_Gtk.cpp
--- a/src/arch/LoadingWindow/LoadingWindow_Gtk.cpp Fri Jan 13 00:39:56 2012 -0500
+++ b/src/arch/LoadingWindow/LoadingWindow_Gtk.cpp Sat Jan 14 10:52:30 2012 +0200
@@ -1,4 +1,5 @@
#include "global.h"
+#include "ProductInfo.h"
#include "RageLog.h"
#include "RageFileManager.h"
#include "RageUtil.h"
@@ -29,7 +30,12 @@
{
ASSERT( Handle == NULL );
- Handle = dlopen( RageFileManagerUtil::sDirOfExecutable + "/" + "GtkModule.so", RTLD_NOW );
+ #if defined(EXT_DATADIR)
+ Handle = dlopen( EXT_DATADIR + RString("/") + RString(PRODUCT_FAMILY).MakeLower() + "/" + "GtkModule.so", RTLD_NOW );
+ #else
+ Handle = dlopen( RageFileManagerUtil::sDirOfExecutable + "/" + "GtkModule.so", RTLD_NOW );
+ #endif
+
if( Handle == NULL )
return ssprintf( "dlopen(): %s", dlerror() );
diff -r 23cf2445ee5d src/arch/LoadingWindow/LoadingWindow_GtkModule.cpp
--- a/src/arch/LoadingWindow/LoadingWindow_GtkModule.cpp Fri Jan 13 00:39:56 2012 -0500
+++ b/src/arch/LoadingWindow/LoadingWindow_GtkModule.cpp Sat Jan 14 10:52:30 2012 +0200
@@ -1,4 +1,5 @@
#include "global.h"
+#include "ProductInfo.h"
#include "LoadingWindow_GtkModule.h"
#include "RageUtil.h"
#include "RageSurface.h"
@@ -15,7 +16,19 @@
extern "C" const char *Init( int *argc, char ***argv )
{
// Need to use external library to load this image. Native loader seems broken :/
+#if defined(EXT_DATADIR)
+ gchar splash_image_path[50] = EXT_DATADIR;
+ gchar product[] = PRODUCT_FAMILY;
+ int i,plen = strlen(product);
+ for (i = 0; i < plen; i++)
+ product[i] = tolower(product[i]);
+ strcat(splash_image_path,"/");
+ strcat(splash_image_path,product);
+ strcat(splash_image_path,"/Data/splash.png");
+#else
const gchar *splash_image_path = "Data/splash.png";
+#endif
+
GtkWidget *vbox;
gtk_disable_setlocale();

View File

@ -1,75 +0,0 @@
From 8afe1cf17c5d58182f010f540c49a2648f5c2f57 Mon Sep 17 00:00:00 2001
From: Vincent Laviron <vincent.laviron@gmail.com>
Date: Thu, 3 Apr 2014 17:28:13 +0200
Subject: [PATCH] FFMpeg: Fix uninitialized AVFrame Fixes crashes with recent
version of libav and ffmpeg on Linux while attempting to play a video
---
src/arch/MovieTexture/MovieTexture_FFMpeg.cpp | 11 ++++++-----
src/arch/MovieTexture/MovieTexture_FFMpeg.h | 2 +-
2 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/src/arch/MovieTexture/MovieTexture_FFMpeg.cpp b/src/arch/MovieTexture/MovieTexture_FFMpeg.cpp
index 51cfbd5..923e602 100644
--- a/src/arch/MovieTexture/MovieTexture_FFMpeg.cpp
+++ b/src/arch/MovieTexture/MovieTexture_FFMpeg.cpp
@@ -112,6 +112,7 @@ MovieDecoder_FFMpeg::MovieDecoder_FFMpeg()
m_fctx = NULL;
m_pStream = NULL;
m_iCurrentPacketOffset = -1;
+ m_Frame = avcodec::av_frame_alloc();
Init();
}
@@ -267,7 +268,7 @@ int MovieDecoder_FFMpeg::DecodePacket( float fTargetTime )
m_Packet.data = m_Packet.size ? m_Packet.data : NULL;
int len = avcodec::avcodec_decode_video2(
m_pStream->codec,
- &m_Frame, &iGotFrame,
+ m_Frame, &iGotFrame,
&m_Packet );
CHECKPOINT;
@@ -286,9 +287,9 @@ int MovieDecoder_FFMpeg::DecodePacket( float fTargetTime )
continue;
}
- if( m_Frame.pkt_dts != AV_NOPTS_VALUE )
+ if( m_Frame->pkt_dts != AV_NOPTS_VALUE )
{
- m_fTimestamp = (float) (m_Frame.pkt_dts * av_q2d(m_pStream->time_base));
+ m_fTimestamp = (float) (m_Frame->pkt_dts * av_q2d(m_pStream->time_base));
}
else
{
@@ -299,7 +300,7 @@ int MovieDecoder_FFMpeg::DecodePacket( float fTargetTime )
/* Length of this frame: */
m_fLastFrameDelay = (float) av_q2d(m_pStream->time_base);
- m_fLastFrameDelay += m_Frame.repeat_pict * (m_fLastFrameDelay * 0.5f);
+ m_fLastFrameDelay += m_Frame->repeat_pict * (m_fLastFrameDelay * 0.5f);
++m_iFrameNumber;
@@ -350,7 +351,7 @@ void MovieDecoder_FFMpeg::GetFrame( RageSurface *pSurface )
}
avcodec::sws_scale( m_swsctx,
- m_Frame.data, m_Frame.linesize, 0, GetHeight(),
+ m_Frame->data, m_Frame->linesize, 0, GetHeight(),
pict.data, pict.linesize );
}
diff --git a/src/arch/MovieTexture/MovieTexture_FFMpeg.h b/src/arch/MovieTexture/MovieTexture_FFMpeg.h
index 0c017d8..f4d25ef 100644
--- a/src/arch/MovieTexture/MovieTexture_FFMpeg.h
+++ b/src/arch/MovieTexture/MovieTexture_FFMpeg.h
@@ -63,7 +63,7 @@ class MovieDecoder_FFMpeg: public MovieDecoder
int DecodePacket( float fTargetTime );
avcodec::AVStream *m_pStream;
- avcodec::AVFrame m_Frame;
+ avcodec::AVFrame *m_Frame;
avcodec::PixelFormat m_AVTexfmt; /* PixelFormat of output surface */
avcodec::SwsContext *m_swsctx;

View File

@ -1,120 +0,0 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit games autotools eutils git-r3
DESCRIPTION="Stepmania 5 sm-ssc branch"
HOMEPAGE="https://github.com/stepmania/stepmania"
SRC_URI=""
EGIT_REPO_URI="https://github.com/stepmania/stepmania.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug X gtk +jpeg +mad +vorbis +network +ffmpeg sse2 bundled-libs"
DEPEND="gtk? ( x11-libs/gtk+:2 )
media-libs/alsa-lib
mad? ( media-libs/libmad )
vorbis? ( media-libs/libvorbis )
media-libs/libpng
jpeg? ( virtual/jpeg )
ffmpeg? ( >=virtual/ffmpeg-0.5 )
virtual/glu
x11-libs/libXrandr
media-libs/glew
virtual/opengl
!bundled-libs? ( dev-libs/libpcre dev-libs/jsoncpp )"
remove_bundled_lib() {
local blib_prefix
blib_prefix="${S}/extern"
einfo "Removing bundled library $1 ..."
rm -rf "${blib_prefix}/$1" || die "Failed removing bundled library $1"
}
remove_dev_theme() {
local theme_dir
theme_dir="${S}/Themes"
einfo "Removing dev theme $1 ..."
rm -rf "${theme_dir}/$1" || die "Failed removing dev theme $1"
}
src_prepare() {
# Remove bundled libs, to know if they become forked as lua already is.
if ! use bundled-libs; then
remove_bundled_lib "ffmpeg"
remove_bundled_lib "libjpeg"
remove_bundled_lib "libpng"
#remove_bundled_lib "libtomcrypt"
#remove_bundled_lib "libtommath"
remove_bundled_lib "mad-0.15.1b"
remove_bundled_lib "pcre"
remove_bundled_lib "vorbis"
remove_bundled_lib "zlib"
fi
# Remove dev themes
remove_dev_theme "default-dev-midi"
remove_dev_theme "HelloWorld"
remove_dev_theme "MouseTest"
remove_dev_theme "rsr"
# Apply various patches
# 00 - 09: Filepath changes
# 10 - 19: De-bundle patches
# 20 - 29: Other fixes
# 30 - 39; Non-important gameplay patches
EPATCH_SOURCE="${FILESDIR}" EPATCH_SUFFIX="patch" \
EPATCH_FORCE="no" epatch || die "Patching failed!"
# This is used instead of running StepMania's autogen.sh
eautoreconf
}
src_configure() {
myconf=""
if ! use bundled-libs; then
einfo "Disabling bundled libraries.."
myconf="${myconf} --with-system-pcre --with-system-ffmpeg"
fi
egamesconf \
--disable-dependency-tracking \
--enable-lua-binaries \
--with-extdatadir \
$(use_enable gtk gtk2) \
$(use_with debug) \
$(use_with X x) \
$(use_with jpeg) \
$(use_with mad mp3) \
$(use_with vorbis) \
$(use_with network) \
$(use_with ffmpeg) \
$(use_with sse2) \
${myconf}
}
src_install() {
dogamesbin src/${PN} || die "dogamesbin $sm-ssc failed"
insinto "${GAMES_DATADIR}"/${PN}
if use gtk ; then
doins src/GtkModule.so || die "doins GtkModule.so failed"
fi
doins -r Announcers _assets BackgroundEffects BackgroundTransitions \
BGAnimations Characters Courses Data NoteSkins Songs Themes || die "doins failed"
#dodoc -r Docs || die "dodoc failed"
newicon "Themes/default/Graphics/Common window icon.png" ${PN}.png
make_desktop_entry ${PN} Stepmania
prepgamesdirs
# Ensure that game can write to Data folder
fperms -R 775 "${GAMES_DATADIR}"/${PN}/Data
}

View File

@ -1,74 +0,0 @@
#!/bin/sh
create_wine_dir ()
{
# get params
winedir=${1:?} ; shift # only accept absolute path without trailing slash
# exec wine command
if [ ! -e "$winedir" ] ; then
mkdir -p "$winedir"
fi
WINEPREFIX="$winedir" wineboot
# change softlink to real directory in user directory
userdir="$winedir/drive_c/users/$(id -un)"
SAVEIFS=$IFS
IFS=$'\n'
for f in `find "$userdir" -print`
do
if [ ! -L "$f" ] ; then continue ; fi
unlink $f
mkdir $f
done
}
create_link ()
{
# get params
srcdir=${1:?} ; shift # only accept absolute path without trailing slash
dstdir=${1:?} ; shift # same as above
dstdir_in="$dstdir/$(basename $srcdir)"
# make dstdir in srcdir
if [ ! -e "$dstdir_in" ] ; then
mkdir -p "$dstdir_in"
fi
# do the job
SAVEIFS=$IFS
IFS=$'\n'
for srcf in `find "$srcdir" -print`
do
# get inner filename
f=${srcf:((${#srcdir}+1))}
if [ "$f" == "" ] ; then continue ; fi
# do the job
if [[ -d "$srcf" && ! -L "$srcf" ]] ; then
# create directory structure
mkdir -p "$dstdir_in/$f"
else
# create softlink
ln -s -f -t `dirname "$dstdir_in/$f"` $srcf
fi
done
IFS=$SAVEIFS
}
# Variables
GAMEDIR= # fill by ebuild
DATADIR= # fill by ebuild
# Create wine directory
create_wine_dir "$DATADIR"
# Make links of "$GAMEDIR/*" to "$DATADIR"
if [ ! -e "$DATADIR/drive_c/TOTALA" ] ; then
create_link "$GAMEDIR/TOTALA" "$DATADIR/drive_c"
fi
# run the game
cd "$DATADIR/drive_c/TOTALA"
WINEPREFIX="$DATADIR" wine TotalA.exe

View File

@ -1,98 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit eutils games
DESCRIPTION="Total Annihilation"
HOMEPAGE=""
LICENSE="as-is"
SLOT="0"
KEYWORDS=""
IUSE="core-contingency tae battle-tactics"
DEPEND="app-arch/unzip
app-arch/p7zip"
RDEPEND=">=app-emulation/wine-1.4.1[win32,-win64]"
RESTRICT="fetch strip"
SRC_URI="Total.Annihilation.CD1.zip Total.Annihilation.CD2.iso Total.Annihilation.The.Core.Contingency.iso Total.Annihilation.Battle.Tactics.iso
ta1x-31c.zip installed-ta.zip"
src_unpack() {
# 7z x "${FILESDIR}/Total.Annihilation.CD1.iso" -o"${WORKDIR}/ta_cd1"
unzip "${DISTDIR}/Total.Annihilation.CD1.zip" -d "${WORKDIR}/ta_cd1" # cd1.iso can't be decompressed by p7zip
7z x "${DISTDIR}/Total.Annihilation.CD2.iso" -o"${WORKDIR}/ta_cd2"
7z x "${DISTDIR}/Total.Annihilation.The.Core.Contingency.iso" -o"${WORKDIR}/ta_cd3"
7z x "${DISTDIR}/Total.Annihilation.Battle.Tactics.iso" -o"${WORKDIR}/ta_cd4"
unzip "${DISTDIR}/ta1x-31c.zip" -d "${WORKDIR}/ta1x-31c"
# Restruct the directory.
mkdir -v "${WORKDIR}/TOTALA"
# Should be extracted from the ZRB files in ta_cd1, but we don't know the ZRB file format
unzip "${DISTDIR}/installed-ta.zip" -d "${WORKDIR}/installed-ta"
mv -vf "${WORKDIR}/installed-ta"/* "${WORKDIR}/TOTALA"
rm -rf "${WORKDIR}/installed-ta"
mv -vf "${WORKDIR}/ta1x-31c"/* "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd1/totala3.hpi" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd2/totala4.hpi" "${WORKDIR}/TOTALA"
if use core-contingency ; then
for f in "${WORKDIR}/ta_cd3/CC"/* ; do # move ta_cd3/CC/* ignoring filename case
lwrf=`echo "$(basename $f)" | tr '[:upper:]' '[:lower:]'`
if [ "$lwrf" == "totala.exe" ] ; then
lwrf="TotalA.exe"
fi
mv -vf "$f" "${WORKDIR}/TOTALA/${lwrf}"
done
fi
if use tae ; then
mv -vf "${WORKDIR}/ta_cd3/TAE/Bitmaps" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/camps" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/TAE.EXE" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/TAE.HLP" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/TAEREAD.DOC" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/TAEREAD.TXT" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/Example.tdf" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/Example.ufo" "${WORKDIR}/TOTALA"
mv -vf "${WORKDIR}/ta_cd3/TAE/worlds.hpi" "${WORKDIR}/TOTALA"
fi
if use battle-tactics ; then
mv -vf "${WORKDIR}/ta_cd4/bt"/* "${WORKDIR}/TOTALA"
fi
rm -rf "${WORKDIR}/ta1x-31c"
rm -rf "${WORKDIR}/ta_cd4"
rm -rf "${WORKDIR}/ta_cd3"
rm -rf "${WORKDIR}/ta_cd2"
rm -rf "${WORKDIR}/ta_cd1"
}
src_prepare() {
# Prepare the wrapper script
sed -e "s/^GAMEDIR=.*$/GAMEDIR=\/opt\/total-annihilation/g" \
-e "s/^DATADIR=.*$/DATADIR=~\/.local\/share\/total-annihilation/g" "${FILESDIR}/total-annihilation" > "${WORKDIR}/total-annihilation"
}
src_install() {
dodir "${GAMES_PREFIX_OPT}/total-annihilation"
cp -r "TOTALA" "${D}/${GAMES_PREFIX_OPT}/total-annihilation"
dogamesbin "total-annihilation"
#doicon "${FILESDIR}/nfs9.png"
domenu "${FILESDIR}/total-annihilation.desktop"
prepgamesdirs
}

View File

@ -1,36 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
AUTOTOOLS_IN_SOURCE_BUILD=1
inherit git-r3 autotools-utils
DESCRIPTION="MonkVG is an OpenVG 1.1 like vector graphics API implementation
currently using an OpenGL ES backend"
HOMEPAGE="https://github.com/micahpearlman/MonkVG"
SRC_URI=""
EGIT_REPO_URI="https://github.com/microcai/MonkVG.git"
#https://github.com/micahpearlman/${PN}.git"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
RDEPEND="virtual/opengl
media-libs/glew"
DEPEND="${RDEPEND}"
src_prepare(){
eautoreconf
}
src_configure(){
econf $(use_enable static-libs static)
}

View File

@ -1 +0,0 @@
DIST package-query-1.1.tar.gz 375186 SHA256 fcf6d27aee4ca15ba8cfeb02fa0cc2a270ca7389fdab91e7b31d7c1f599f2a92 SHA512 b228c7012b8d8a913bdd05d498336075b99c5d9b34832c401085fdd5270f9cb2419c628234fed7c2fe5c950b083659dc463ffdea69c08e52fdc503f73a607298 WHIRLPOOL 86316d5ab9802ec82ba112e9a501583a31dd1868654c6d204af8ed373854786e097a05f68a58c53b92d9f0ae6f30bde9e2414d507cb2f2779d7d11ead88ee7c9

View File

@ -1,42 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit autotools autotools-utils eutils
DESCRIPTION="Query ALPM and AUR"
HOMEPAGE="http://gitweb.archlinux.fr/package-query.git/"
SRC_URI="http://mir.archlinux.fr/~tuxce/releases/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
dev-libs/yajl
>=sys-apps/pacman-4.0
<=sys-apps/pacman-4.1
"
RDEPEND="${DEPEND}"
src_prepare() {
eautoreconf
}
src_configure() {
local myeconfargs=(
--prefix=/usr
--sysconfdir=/etc
--localstatedir=/var
--with-aur-url=https://aur.archlinux.org
)
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
}

View File

@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
EAPI=6
inherit nsplugins

View File

@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
EAPI=6
inherit nsplugins

View File

@ -1 +0,0 @@
DIST freshplayerplugin-0.2.3.tar.gz 402126 SHA256 b28ae17dec274aa6eb819d496088efbc503aa6bfba09192e2f08200ecf66d10b

View File

@ -1,52 +0,0 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit cmake-utils nsplugins
DESCRIPTION="PPAPI-host NPAPI-plugin adapter"
HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="pulseaudio"
RDEPEND="dev-libs/libconfig
dev-libs/libevent[threads]
media-libs/alsa-lib
media-libs/mesa[gles2]
x11-libs/gtk+:2
x11-libs/pango
pulseaudio? ( media-sound/pulseaudio )
!www-plugins/adobe-flash
|| (
www-plugins/chrome-binary-plugins[flash]
www-client/google-chrome
www-client/google-chrome-beta
www-client/google-chrome-unstable
)
"
DEPEND="${RDEPEND}
dev-util/ragel
virtual/pkgconfig
"
DOCS=( ChangeLog README.md )
src_install() {
default
insinto /etc
doins data/freshwrapper.conf.example
exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
doexe ${BUILD_DIR}/libfreshwrapper-pepperflash.so
}

View File

@ -1 +0,0 @@
DIST iSecurityUMS-linux.tar.gz 774112 SHA256 14dd1e3380047de38682db475cb0806653bd9869ba78c888a3dd6c76d7e521c7

View File

@ -1,38 +0,0 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v3
# $Header: $
EAPI=7
inherit nsplugins
DESCRIPTION="SA-iSecurity Plug-in for UMS"
HOMEPAGE="http://www.chinapay.com"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://account.chinapay.com/person/setup/${PN}-linux.tar.gz"
LICENSE="unknown"
RESTRICT="strip mirror"
SLOT="0"
IUSE=""
RDEPEND="dev-libs/openssl"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-install
src_compile() {
if use amd64; then
tar xvzf ${S}/${PN}-linux-x86_64.tar.gz
elif use x86; then
tar xvzf ${S}/${PN}-linux-i686.tar.gz
fi
}
src_install() {
insinto "/opt/netscape/plugins"
doins "${S}/${PN}.so"
inst_plugin "/opt/netscape/plugins/${PN}.so"
}

View File

@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v3
# $Header: $
EAPI=7
EAPI=6
inherit nsplugins versionator
inherit nsplugins
#MY_PV="$(get_version_component_range 1-2)"

View File

@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=7
EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=true
inherit distutils-r1 versionator

View File

@ -1,3 +0,0 @@
DIST lunar-calendar-2.4.1.tar.gz 419205 SHA256 8bed2f3f385b2e9103331e2f536dfb488d8576550b62788ff8dfcee6d19f5ce3
DIST lunar-calendar-3.0.0.tar.gz 418283 SHA256 8cdbf367250e48774f79a10897126e0e92171b49167959b72554e583999a3294
DIST lunar-calendar_0.3.1.orig.tar.gz 76825 SHA256 e243eca4f559bae82c6243485b2e4a3d6dea965acc8d9dc2794ade88e41733ed

View File

@ -1,34 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v3
# $Header: $
EAPI=7
inherit fdo-mime versionator
SRC_URI="http://packages.linuxdeepin.com/deepin/pool/main/l/${PN}/${PN}_${PV}.orig.tar.gz"
DESCRIPTION="Chinese Lunar Calendar library fork by LinuxDeepin project"
HOMEPAGE="http://www.linuxdeepin.com"
LICENSE="GPL-2+"
SLOT="deepin"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-libs/gobject-introspection
dev-libs/glib:2
x11-libs/gtk+:2
dev-libs/dtk-widget
dev-libs/lunar-date
!x11-libs/lunar-calendar:2"
DEPEND="${RDEPEND}
dev-util/gtk-doc"
S="${WORKDIR}"
src_prepare() {
#sed -i 's|liblunar_calendar_preload_2_0_include_HEADERS =\
# $(source_h)|#liblunar_calendar_preload_2_0_include_HEADERS = $(source_h)|g'\
# lunar-calendar/Makefile.am
./autogen.sh
}

View File

@ -1,37 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit gnome2
DESCRIPTION="Chinese Lunar Library Gtk+ widget"
HOMEPAGE="http://liblunar.googlecode.com"
SRC_URI="http://liblunar.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~x86 ~amd64"
IUSE="doc python"
RDEPEND="${RDEPEND}
>=dev-libs/lunar-date-2.4.0
doc? ( >=dev-util/gtk-doc-1 )
python? (
>=dev-python/pygobject-2.11.5
>=dev-python/pygtk-2.9.7
)
>=x11-libs/gtk+-2.16:2
"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
>=dev-util/intltool-0.35"
DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
G2CONF="$(use_enable python) $(use_enable doc)"
}

View File

@ -1,32 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=7
inherit gnome2
DESCRIPTION="Chinese Lunar Library Gtk+ widget"
HOMEPAGE="http://liblunar.googlecode.com"
SRC_URI="http://liblunar.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="3"
KEYWORDS="~x86 ~amd64"
IUSE=""
RDEPEND="${RDEPEND}
>=dev-libs/lunar-date-2.4.0
x11-libs/gtk+:3
"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
>=dev-util/intltool-0.35"
DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
G2CONF="$(use_enable python) $(use_enable doc)"
}

View File

@ -1,11 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
<email>yetist@gmail.com</email>
<description>maintaining in gentoo china overlay</description>
</maintainer>
<longdescription>Chinese Lunar Library</longdescription>
</pkgmetadata>