app-i18n/zh-autoconvert: add 0.3.16_p10, drop 0.3.16_p7

Signed-off-by: liuyujielol <2073201758GD@gmail.com>
This commit is contained in:
liuyujielol 2025-02-17 15:50:54 +08:00 committed by peeweep
parent aec8ef743d
commit 185994d0c0
3 changed files with 22 additions and 73 deletions

View File

@ -1 +1 @@
DIST zh-autoconvert-debian-0.3.16-7.tar.gz 296045 BLAKE2B 80fc4541345a8360ef7be24f890deda26530b8baf54db1695b1001a40b4377c7b20c965d00a42b45e309fa83074eb84d58b86f758a167b38268fd5366b2be711 SHA512 86fc8567d754505e29ed4060940bacd0bcf9a8a81b22595d1a2c9c1990865dee1ff872de634c0b0697668c2402184a9181fbc4dffeb739dd19b202a94593c3e8
DIST zh-autoconvert-debian-0.3.16-10.tar.gz 296774 BLAKE2B 1a8caac4063189fb4d8be1c68a21416142a6195a458273cfc3af2eade9dd26bf6f96eb3a069a9a2d6525d59be6cd6554df5614933f12a8933579b034c9fff683 SHA512 463980990521231c8633f273b7130018b27885c71b1d147c3c49a36518de860f3194df12632506f103b40ab82d47ced4c0e739239b24041ebee64e70f0c21d28

View File

@ -1,45 +0,0 @@
diff --git a/Makefile b/Makefile
index 66e8bea..e94aa3f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
CC=gcc
-CFLAG=-O2 -g -Wall -Iinclude
+# CFLAG=-O2 -g -Wall -Iinclude
+CFLAGS+= -Wall -Iinclude
LIBS= -Llib -lhz
.PHONY: all hzlib clean install-home install
@@ -10,9 +11,9 @@ all: autob5 autogb hzlib
autob5: autogb
rm -f autob5;ln -s autogb autob5
autogb:autogb.c hzlib
- $(CC) $(CFLAG) $(LIBS) autogb.c -lhz -o autogb
+ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) autogb.c -lhz -o autogb
autogb-static:autogb.c hzlib
- $(CC) $(CFLAG) autogb.c lib/libhz.a -o autogb
+ $(CC) $(CFLAGS) $(LDFLAGS) autogb.c lib/libhz.a -o autogb
hzlib:
cd hzconvert;make
xchat-plugins:
diff --git a/hzconvert/Makefile b/hzconvert/Makefile
index d8d4d19..2809d0a 100644
--- a/hzconvert/Makefile
+++ b/hzconvert/Makefile
@@ -1,5 +1,5 @@
CC=gcc -I../include
-CFLAGS=-O2 -Wall -g -D_REENTRANT
+CFLAGS+=-Wall -D_REENTRANT
SHARED_LIB=libhz.so
SHARED_LIB_MAJOR=$(SHARED_LIB).0
SHARED_LIB_MINOR=$(SHARED_LIB_MAJOR).0
@@ -15,7 +15,7 @@ STATIC_OBJS=b2g.static.o b2u.static.o g2u.static.o hz2gb.static.o b2g_tables.sta
all: share-lib static-lib
share-lib: $(OBJS)
- gcc -fPIC -shared -Wl,-soname,$(SHARED_LIB_MAJOR) -o ../lib/$(SHARED_LIB_MINOR) $(OBJS) -ldl
+ gcc -fPIC -shared -Wl,-soname,$(SHARED_LIB_MAJOR) $(LDFLAGS) -o ../lib/$(SHARED_LIB_MINOR) $(OBJS) -ldl
rm -f ../lib/$(SHARED_LIB_MAJOR)
rm -f ../lib/$(SHARED_LIB)
cd ../lib;ln -s $(SHARED_LIB_MINOR) $(SHARED_LIB_MAJOR)

View File

@ -1,23 +1,22 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit multilib
EAPI=8
MY_PV="${PV/_p/-}"
DESCRIPTION="Chinese HZ/GB/BIG5/UNI/UTF7/UTF8 encodings auto-converter"
HOMEPAGE="https://packages.debian.org/stable/source/zh-autoconvert"
SRC_URI="https://salsa.debian.org/chinese-team/zh-autoconvert/-/archive/debian/${MY_PV}/zh-autoconvert-debian-${MY_PV}.tar.gz"
SRC_URI="
https://salsa.debian.org/chinese-team/zh-autoconvert/-/archive/debian/${MY_PV}/zh-autoconvert-debian-${MY_PV}.tar.gz
"
S="${WORKDIR}/${PN}-debian-${MY_PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
S="${WORKDIR}/${PN}-debian-${MY_PV}"
PATCHES=(
"${S}/debian/patches/001-build-static-library.patch"
"${S}/debian/patches/002-chdir-before-symlink.patch"
@ -35,33 +34,28 @@ PATCHES=(
"${S}/debian/patches/014-convert-comments-to-utf8.patch"
"${S}/debian/patches/015-convert-docs-to-utf8.patch"
"${S}/debian/patches/016-not-compile-xchat-plugin.patch"
"${S}/debian/patches/0017-Make-function-definition-explicit.patch"
)
src_prepare() {
default
# don't build xchat-plugins
# so don't depend on gtk+-1.2 anymore
sed -i -e 's/[ ]*xchat-plugins$//' Makefile
}
# respect user flags
find "${S}" -name 'Makefile' -exec sed -i \
-e 's|-O2||g' \
-e 's|-g||g' \
{} +
src_compile() {
emake -j1 || die "emake failed"
}
src_install() {
dobin autogb
dosym autogb /usr/bin/autob5
if use static-libs; then
dolib.a lib/libhz.a
if use !static-libs; then
# static libs .a
sed -i \
-e 's|install -m 755 lib/libhz.a $(DESTDIR)/usr/lib|# \0|' \
"${S}/Makefile" || die "Failed to remove static-libs"
fi
dolib.so lib/libhz.so.0.0
# install to /usr/$(get_libdir)
sed -i \
-e "s|/usr/lib|/usr/$(get_libdir)|g" \
"${S}/Makefile" || die "Failed to patch Makefile"
dosym libhz.so.0.0 /usr/$(get_libdir)/libhz.so.0
dosym libhz.so.0 /usr/$(get_libdir)/libhz.so
insinto /usr/include
doins include/*.h
}